Liferay DXP 7.2 Compatibility Matrix

Liferay Digital Experience Platform 7.2 is only supported under the following configurations:

Type Compatible Environments

Application Server

  • JBoss EAP 7.1
  • JBoss EAP 7.2
  • Tomcat 9.0
  • Weblogic 12c Release 2
  • Websphere 9.0
  • Wildfly 11.0
  • Wildfly 16.0

Database

  • Amazon Aurora
  • DB2 10.5
  • DB2 11.1
  • MariaDB 10.2
  • MySQL 5.7
  • MySQL 8.0
  • Oracle 12c Release 2
  • Oracle 19c
  • Postgres 10
  • Postgres 11
  • SQL Server 2017
  • SQL Server 2019

Operating System

  • AIX 7.x
  • Alpine Linux 3.8
  • Amazon Linux 2
  • CentOS 7
  • Debian 9
  • Oracle Linux 7
  • Oracle Solaris 11
  • RedHat Enterprise Linux 7
  • SUSE Enterprise Linux 12
  • SUSE Enterprise Linux 15
  • Ubuntu LTS 18.04
  • Windows Server 2016
  • Windows Server 2019

Desktop Browser*

  • Chrome 65
  • Chrome (Latest)
  • Edge (Latest)
  • Firefox (Latest)
  • Internet Explorer 11 (Limited)
  • Safari 11
  • Safari 12

Mobile Browser**

  • Chrome (Latest)
  • Safari (Latest)

JDK***

  • IBM J9 JDK 8
  • Oracle JDK 8
  • Oracle JDK 11 
  • All Java Technical Compatibility Kit (TCK) compliant builds of Java 11 and Java 8

Cloud Services

  • Amazon Elastic Compute Cloud****
  • Amazon Relational Database Service****
  • Amazon S3
  • Azure Files
  • Azure SQL Databases
  • Azure Virtual Machines
  • Google Cloud Compute Engine
  • Google Cloud SQL

Search Engine*****

  • Elasticsearch 6.1.x - 6.8.x 
  • Elasticsearch 7.3.x - 7.7.x (Fix Pack 2+)
  • Solr 7.5.x

 

For more information on configurations and limitations with Application Servers and Databases that are compatible with Liferay DXP, please refer to the Liferay User Guide.

* Desktop Browser support exclusions:
1. Versions of browsers that were released after a major Liferay version release have not been tested and support for these newer browser releases will be provided as a commercially reasonable effort only and may be included in subsequent service releases at Liferay's discretion.
2. Versions of browsers that were supported with an initial release of a Liferay version that have reached the end of their product lifecycle are no longer tested in subsequent service releases and support for those older browser releases will be provided as commercially reasonable effort only.
3. Internet Explorer Compatibility modes for all relevant versions are not supported.
4. Limited support shall be provided for Internet Explorer 11 on a case-by-case basis. Internet Explorer 11 has performance limitations which prohibit it from utilizing the latest technologies effectively without experiencing significant degradation.

** Mobile Browser support exclusions:
1. Liferay will support access to information (e.g. reading content and navigation through pages), navigation menus, and basic responsiveness of modules for the latest versions of mobile browsers only. For more information on Liferay's mobile support policy, please refer to the Help Center.

*** JDK Certification is for runtime only. JDK 8 is required to build or compile Liferay DXP projects.

**** Amazon EC2 and RDS are only supported with environments on the Liferay DXP 7.2 Compatibility Matrix

***** Elasticsearch 7 requires the "Liferay Connector to Elasticsearch 7" app from Marketplace

Liferay DXP does not restrict the use of VM/Container strategy as long as the Application Server/Database/JDK/Operating System are supported within our compatibility matrix. Customers will be responsible for configuring the VM/Container appropriately. 

Liferay DXP Compatibility Matrix: Updated 07/01/2020

Download PDF

Was this article helpful?
3 out of 4 found this helpful