Liferay DXP 7.3 & Liferay Commerce 3.0 Compatibility Matrix

Liferay Digital Experience Platform 7.3 and Liferay Commerce 3.0 are only supported under the following certified configurations: 

Application Server

  • JBoss EAP 7.2
  • JBoss EAP 7.3
  • Tomcat 9.0
  • Websphere 9.0
  • Weblogic 12c Release 2
  • Wildfly 14.0
  • Wildfly 17.0

For more information on configurations and limitations with Databases that are compatible with Liferay DXP, please refer to the Liferay User Guide.

Database

  • Amazon Aurora
  • DB2 11.5
  • Maria DB 10.2
  • Maria DB 10.4
  • MySQL 5.7
  • MySQL 8.0
  • Oracle 19c
  • Postgres 11
  • Postgres 12
  • SQL Server 2017
  • SQL Server 2019

For more information on configurations and limitations with Application Servers compatible with Liferay DXP, please refer to the Liferay User Guide.

Operating System

  • Alpine Linux 3.10
  • Amazon Linux 2
  • CentOS 7
  • CentOS 8
  • Debian 10
  • IBM AIX 7.2
  • Oracle Linux 7
  • Oracle Solaris 11
  • Red Hat Enterprise Linux 7
  • Red Hat Enterprise Linux 8
  • SUSE Enterprise Linux 12
  • SUSE Enterprise Linux 15
  • Ubuntu LTS 18.04
  • Windows Server 2016
  • Windows Server 2019

 

Desktop Browser

  • Chrome 65
  • Chrome (Latest)
  • Edge (Latest)
  • Firefox (Latest)
  • Firefox ESR (Latest)
  • Internet Explorer 11 (Limited)
  • Safari 12
  • Safari 13

For more information on configurations and limitations with Desktop Browsers that are compatible with Liferay DXP, please refer to the Support Policy.

Mobile Browser

  • Chrome (Latest)
  • Safari (Latest)

 

Liferay will support access to information (e.g. reading content and navigation through pages), navigation menus, and basic responsiveness of modules for the latest versions of mobile browsers only. For more information on Liferay’s mobile support policy, please refer to the Help Center.

JDK

  • IBM J9 JDK 8
  • Oracle JDK 8
  • Oracle JDK 11 
  • All Java Technical Compatibility Kit (TCK) compliant builds of Java 11 and Java 8

JDK Certification is for runtime only. JDK 8 is required to build or compile Liferay DXP Projects.

Cloud Services

  • Amazon Elastic Compute Cloud (EC2)
  • Amazon Relational Database Service (RDS)
  • Amazon S3
  • Azure Files
  • Azure SQL Databases
  • Azure Virtual Machines
  • Google Cloud Compute
  • Google Cloud SQL

Amazon EC2 and RDS are only supported with environments on the Liferay DXP 7.3 Compatibility Matrix.

Search Engines

  • Elasticsearch 7

 

Refer to the Search Engine Compatibility Matrix for the detailed compatibility including the compatible connector versions and required patch levels.

Notes

Liferay DXP does not restrict the use of VM/Container strategy as long as the Application Server, Database, JDK, and Operating System are certified for use as indicated on the Compatibility Matrix above. Subscribers will be responsible for configuring the VM/Container appropriately.

 

Updated 02/02/2021

Download PDF

Was this article helpful?
3 out of 3 found this helpful