Issues Encountered with Upgrades to Liferay Portal EE Versions

This article is a legacy article. It applies to previous versions of the Liferay product. While the article is no longer maintained, the information may still be applicable.

The following comprises a list of issues that administrators have experienced in running an upgrade, along with the underlying cause as well as the resolution to that particular issue.

Resolution

Issue:

java.sql.SQLException: Invalid SQL statement or JDBC escape, terminating ''' not found.

Cause:
This issue is a result of characters within the database preventing a query from being executed. Typically it can be a result of SQL injection attack attempts on the database. To resolve the issue:

  1. Determine which step of the Upgrade this issue occurs.
  2. Verify the tables which would be involved with this step.
  3. Query the database and clean up any bad data.

Examples:
delete from ResourceCode where name like '%!%';
delete from ResourceCode where name like '%script%';
delete from ResourceCode where name like '%cat%';
delete from ResourceCode where name like '%imgsrc%';
delete from ResourceCode where name like '%frame%';
delete from ResourceCode where name like '%meta%';
delete from ResourceCode where name like '%ACU%';
delete from ResourceCode where name like '%acu%';
delete from ResourceCode where name like '%printf%';
delete from ResourceCode where name like '%/%';
delete from ResourceCode where name like '%\%';

Issue:

com.liferay.portal.kernel.upgrade.UpgradeException: java.sql.SQLException: Cannot insert duplicate key row in object 'dbo.ResourceCode' with unique index 'IX_#######'.

Cause:

The resourceActionId is already present during the upgrade from Portal 5.2 to a later version of Liferay Portal. This is a result of bad data during the permissions migration in the upgrade.

LPS-33364 fix was committed to the VerifyProcess.

Another possible solution would be to perform a data migration from Permissions Algorithm 5 to 6 prior to the upgrade.p>

Issue:

java.sql.SQLException: Invalid column name 'companyId'.

Cause:

During the upgrade, new tables and columns for the next version of Liferay Portal is being created. This exception occurs as a result of having the column name or table already present during the upgrade. To resolve the issue:

  1. Verify which tables should be present in the upgrade version of the portal
  2. Ensure these tables are not present within the legacy database.
  3. These tables are essentially reserved and should not be in use prior to upgrade.

Issue:

No longer able to view Image Gallery images.

Cause:

The Image Gallery portlet is now a legacy portlet and has been removed from later versions of Liferay Portal 6.1 EE.

  1. Determine the legacy image gallery properties (6.0 and earlier).
  2. Place these properties into the upgrade portal-ext.properties file.
  3. During the upgrade, the Image Gallery migration should be triggered and imported into the new Documents and Media portlet

Issue:

Liferay upgrade halts with ALTER TABLE exception.

Cause:

Previous versions of Liferay Portal, during upgrade processes, would attempt to modify all tables within the database - including tables not used by Liferay Portal.

See LPS-29479

Issue:

Hostname invalid property exception.

ERROR [BeanPropertiesImpl:480] jodd.bean.BeanException: Simple property not found: hostname Invalid property: 'AccountImpl#hostname' (actual:'AccountImpl#hostname', forced=false)

jodd.bean.BeanException: Simple property not found: hostname Invalid property: 'AccountImpl#hostname' (actual:'AccountImpl#hostname', forced=false).

Cause:

This results from a previously set virtual host setting which is no longer being referenced.

Verify the virtual host settings are correct for the portal.

Issue:

A particular section of the portal is not rendering such as a missing dockbar, missing portlet, etc.

Cause:

This can be a result of customizations making direct changes to the portal html and themes. This can be from improper unregistering of the customizations. To resolve this:

  1. Verify proper file sizes and names of the missing elements within the HTML/Theme under webapps/ROOT/html or webapps/ROOT/layouttpl.
  2. Replace them with stock and verify if the elements are still missing.

Please be sure to also verify the cache is not affecting the portal from rendering.

Clear out the cache of the web browser

To manually clear the cache for Internet Explorer:
http://support.microsoft.com/kb/260897

To manually clear data for Google Chrome:
http://support.google.com/chrome/bin/answer.py?hl=en&answer=95582

To manually clear cache for Firefox:
http://support.mozilla.org/en-US/kb/clear-cache-delete-temporary-files-fix-issues

Clear temp and work folder

For this step, please shut down the Liferay Portal. Please remove the temp and work folders from the application server. Not all application servers will have these folders created, please refer to application server documentation. Restart the server.
 

Clear app server cache

Under 'Server Administration' settings

Clear content cached by their VM

Clear content cached across the cluster

Clear the database cache.

Issue:

Unable to find theme messages during startup.

Cause:

This is a result of a legacy theme not properly migrated or deployed to the new instance of Liferay. These references may also be attached to custom layouts.

Rebuild and re-deploy the layouts and themes for the new instance of Liferay.

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