Liferay DXP 7.1 互換性マトリクス

Liferay Digital Experience Platform 7.1 は、以下の環境でのみサポートされています。

  認定

アプリケーションサーバ

  • JBoss EAP 7.1
  • JBoss EAP 7.2
  • tcServer 4.0
  • Tomcat 9.0
  • Weblogic 12c Release 2
  • Websphere 8.5.5 Fix Pack 11+
  • Websphere 9.0
  • Wildfly 10.0
  • Wildfly 11.0
  • Wildfly 14.0
  • Wildfly 16.0

データベース

  • Amazon Aurora
  • DB2 10.5
  • DB2 11.1
  • MariaDB 10.2
  • MySQL 5.7
  • Oracle Database 12c Release 2
  • Oracle Database 19c
  • PostgreSQL 9.6
  • PostgreSQL 10
  • PostgreSQL 11
  • SQL Server 2016
  • SQL Server 2017
  • Sybase ASE 16

オペレーティングシステム

  • Alpine Linux 3.8
  • Amazon Linux 2
  • CentOS 7
  • Debian 9
  • IBM AIX 7.1
  • Oracle Linux 6
  • Oracle Linux 7
  • Oracle Solaris 11
  • RedHat Enterprise Linux 7
  • RedHat Enterprise Linux 8
  • SUSE Enterprise Linux 12
  • Ubuntu LTS 16.04
  • Windows Server 2016

デスクトップブラウザ*

  • Chrome (最新版)
  • Edge (最新版)
  • Firefox ESR 52
  • Internet Explorer 11
  • Safari 11

モバイルブラウザ**

  • Chrome (最新版)
  • Safari (最新版)

JDK***

  • IBM J9 JDK 8
  • Oracle JDK 11
  • Oracle JDK 8 
  • すべてJava 11及びJava 8のJava Technical Compatibility Kit (TCK) に準拠したビルドです

クラウドサービス****

  • Amazon Elastic Compute Cloud
  • Amazon Relational Database Service
  • Amazon S3
  • Azure Files
  • Azure SQL Databases
  • Azure Virtual Machines
  • Google Cloud Compute Engine
  • Google Cloud SQL

サーチエンジン

  • Elasticsearch 6.1.x
  • Elasticsearch 6.1.x-6.8.x (DXP 7.1 Fix Pack 5+)
  • Solr 7.5.x

 

Liferay DXPと互換性のあるアプリケーションサーバー、データベースの設定方法及び制限に関する詳細情報は、Liferay User Guideをご覧ください。

*デスクトップブラウザサポートの注意
1. Liferayのメジャーバージョンリリース後にリリースされたブラウザのバージョンはテストされておらず、これらの新しいブラウザリリースのサポートは*商業上利用可能な範囲の取り組み*としてのみ提供され、Liferayの裁量で後続のサービスリリースに含まれる場合があります。
2. 製品のライフサイクル終了期に達したLiferayバージョンの初期リリースでサポートされていたブラウザーのバージョンは、今後のサービスリリースではテストされなくなり、それらの古いブラウザーリリースのサポートは*商業上利用可能な範囲の取り組み*としてのみ提供されます。
3. 対応しているバージョンにおけるInternet Explorerの互換性モードは、サポートしていません。
4. 最新版IE11もしくはEdgeをご使用の場合は、メモリリークが発生する可能性があります。詳細は ナレッジベース をご覧ください。

**モバイルブラウザサポートの注意
1. Liferayはモバイルブラウザの最新版にのみ、コンテンツの閲覧やページのナビゲーションなど情報へのアクセス、ナビゲーションメニュー、モジュールの基本的な応答性をサポートします。モバイルサポート方針に関しての詳細は、Help Center をご覧ください。

*** すべてのJDKバージョン11は、DXP 7.1フィックスパック5以降が必要です。JDK認定はランタイム専用です。LiferayDXPプロジェクトをビルドまたはコンパイルするには、 JDK 8が必要です。

****Amazon EC2とRDSはLiferay DXP 7.1 互換性マトリクス記載の環境に限りサポートされます。

Liferay DXPは、アプリケーションサーバ/データベース/JDK/オペレーティングシステムがLiferay DXPの互換性マトリクスに含まれるり、VM/Container ストラテジを制限しません。VM/Containerの適切な設定はお客様自身の責任において行ってください。

Liferay DXP版 互換性マトリックス:更新日2020年08月14日

PDFをダウンロード

この記事は役に立ちましたか?
1人中1人がこの記事が役に立ったと言っています