DXP 7.0 Fix Pack 70: Compatibility changes and deployment notes for Connector to Elasticsearch 6 and Solr 5 Search Engine

Liferay DXP 7.0 Fix Pack 70 and SP10 includes the fixes for LPS-79348, LPS-78857 and LPS-80931.

Part of the changes (namely in LPS-78857) new APIs were added to the com.liferay.portal.search.api module which all Liferay search engine connectors must implement to function properly and to fix the issues described on the two other tickets.

Deployment Impact on Search Connectors

The above means, installation of Fix Pack 70+ or SP10+ also requires to deploy a new version of the following Marketplace applications if they are in use:

(The default com.liferay.portal.search.elasticsearch connector is updated as part of the fix pack.)

Patch Level Requirements/Portal Compatibility

  • Elasticsearch 6へのLiferayコネクタ
    • 1.0.0: DXP 7.0 FP42 through FP69 and SP9
    • 1.0.1+: DXP 7.0 FP70+ or SP10+
  • Liferay Solr 5 Search Engine
    • 1.0.0: DXP 7.0 GA1 through FP34
    • 1.0.1: DXP 7.0 FP35 through FP69 and SP9
    • 1.1.1+ : DXP 7.0 FP70+ or SP10+

トラブルシューティング

Not installing Fix Pack 70+/SP10+ or not deploying the latest version of the mentioned Marketplace applications can lead to various errors. Please refer to the possible scenarios and their symptoms below.

Resolution in all cases: make sure you are using the latest version of the application and your current patch level meet the requirements above.

Deploying Connector to Elasticsearch 6 1.0.1 on DXP 7.0 running on Fix Pack 69 or below

Portal generate the following error upon startup or when deploying the connector:

29-Jan-2019 09:46:56.788 SEVERE [localhost-startStop-1] org.apache.catalina.core.StandardContext.listenerStart Exception sending context initialized event to listener instance of class com.liferay.portal.spring.context.PortalContextLoaderListener
java.lang.RuntimeException: com.liferay.portal.lpkg.deployer.LPKGVerifyException: LPKG validation failed with {[missing requirement com.liferay.portal.search.elasticsearch6.api; version=1.0.4; type=osgi.bundle [caused by: Unable to resolve com.liferay.portal.search.elasticsearch6.api version=1.0.4: missing requirement &(osgi.ee=JavaSE)(version=1.8)]], [missing requirement com.liferay.portal.search.elasticsearch6.impl; version=1.0.20; type=osgi.bundle [caused by: Unable to resolve com.liferay.portal.search.elasticsearch6.impl version=1.0.20: missing requirement com.liferay.petra.string; version=[1.0.0,2.0.0)]]}

Using Connector to Elasticsearch 6 1.0.0 on DXP 7.0 Fix Pack 70/SP10

No results found when searching from the Search Portlet. No errors in the log.

Deploying Solr 5 Search Engine 1.1.1 on DXP 7.0 running on Fix Pack 69 or below

Portal generate the following error upon startup or when deploying the connector:

09:54:16,544 ERROR [Framework Event Dispatcher: Equinox Container: 80dd989a-ab23-0019-110a-f83482724d69][com_liferay_portal_search_solr:97] FrameworkEvent ERROR 
org.osgi.framework.BundleException: Could not resolve module: com.liferay.portal.search.solr [504]_ Unresolved requirement: Import-Package: com.liferay.portal.kernel.search; version="[7.3.0,8.0.0)"_ [Sanitized]
at org.eclipse.osgi.container.Module.start(Module.java:429)

Solr 5 Search Engine 1.0.1 or below on DXP 7.0 Fix Pack 70/SP10

No results found when searching from the Search Portlet. No errors in the log.

この記事は役に立ちましたか?
3人中3人がこの記事が役に立ったと言っています