Log4J 2 <Configuration> is required

Issue

  • When system starts, following error message is showed in the log:
ERROR [Start Level: Equinox Container: 6841ecc3-6984-4344-8287-86848c86a132][Log4jConfigUtil:53] Log4J 2 <Configuration> is required

Environment

  • DXP 7.4

Resolution

  • This error denotes an incorrect syntax in configuration file related to Log4j, included in a custom bundle
  • Thus, you must check your custom bundles and detect which of them includes a META-INF/module-log4j.xml file
  • Then, use the correct syntax; you can use a DXP's file as example, such as

https://github.com/liferay/liferay-portal/blob/master/modules/apps/journal/journal-service/src/main/resources/META-INF/module-log4j.xml 

这篇文章有帮助吗?
0 人中有 0 人觉得有帮助