Liferay DXP 7.2 兼容性列表

Liferay Digital Experience Platform 7.2 仅支持以下配置

  认证过的

应用服务器

  • JBoss EAP 7.1
  • JBoss EAP 7.2
  • Tomcat 9.0
  • Weblogic 12c Release 2
  • Websphere 9.0
  • Wildfly 11.0
  • Wildfly 14.0
  • Wildfly 16.0

数据库

  • Amazon Aurora
  • DB2 10.5
  • DB2 11.1
  • MariaDB 10.2
  • MySQL 5.7
  • MySQL 8.0
  • Oracle 12c Release 2
  • Oracle 19c
  • Postgres 10
  • Postgres 11
  • SQL Server 2017
  • SQL Server 2019

操作系统

  • Amazon Linux 3.8
  • Amazon Linux 2
  • CentOS 7
  • Debian 9
  • IBM AIX 7.x
  • Oracle Linux 7
  • Oracle Solaris 11
  • RedHat Enterprise Linux 7
  • RedHat Enterprise Linux 8
  • SUSE Enterprise Linux 12
  • SUSE Enterprise Linux 15
  • Ubuntu LTS 18.04
  • Windows Server 2016
  • Windows Server 2019

桌面浏览器*

  • Chrome 65
  • Chrome (最新版本)
  • Edge (最新版本)
  • Firefox (最新版本)
  • Internet Explorer 11 (有限的)
  • Safari 11
  • Safari 12

手机浏览器**

  • Chrome (最新版本)
  • Safari (最新版本)

JDK***

  • IBM J9 JDK 8
  • Oracle JDK 8
  • Oracle JDK 11 
  • 所有Java Technical Compatibility Kit(TCK)测试符合Java11和Java8的编译

云服务

  • Amazon Elastic Compute Cloud****
  • Amazon Relational Database Service***
  • Amazon S3
  • Azure Files
  • Azure SQL Databases
  • Azure Virtual Machines
  • Google Cloud Compute Engine
  • Google Cloud SQL

搜索引擎*****

  • Elasticsearch 6.1.x-6.8.x 
  • Elasticsearch 7.3.x - 7.9.x (Fix Pack 2+)
  • Solr 7.5.x

 

想了解更多关于Liferay DXP相兼容的应用服务器和数据库的配置以及局限,请参考Liferay部署指南.

*不支持的桌面浏览器情况:
1. 在Liferay主要版本发布之后发布的浏览器版本并未经过测试,对这些新发布的浏览器仅提供商业上合理范围的支持,并且Liferay将决定是否包含在后续版本发布中。
2. 当Liferay原始发布版本所支持的浏览器版本结束其产品生命周期之后,将不再在后续的发布中进行测试。对这些旧的浏览器将仅提供商业上合理范围内的支持。
3. IE浏览器的兼容性模式都是不支持的。
4. 对于Internet Explorer 11会根据具体情况提供有限的支持。Internet Explorer 11存在性能局限性,使其在运用最新技术的同时会经历性能衰减。

** 不支持的手机浏览器情况:
1. Liferay支持信息访问 (例如通过导航页面去阅读内容),导航菜单,以及最新版本手机浏览器的基本模块响应性。详细支持范围,请参看帮助中心此篇文章

*** JDK证书只针对运行时。生成和编译Liferay DXP项目时JDK8必须安装。

**** 亚马逊EC2和RDS只有在“Liferay DXP 7.2 兼容性列表”里支持的环境才可以得到支持

***** 需要从Marketplace下载 "Liferay Connector to Elasticsearch 7" App才能使用 Elasticsearch 7

Liferay DXP不限制虚拟机/Container方式,只要这些应用服务器/数据库/JDK/操作系统是在”Liferay DXP 7.2 兼容性列表” 所支持的。 

Liferay DXP Compatibility Matrix: Updated 2020年09月01日

Download PDF

这篇文章有帮助吗?
4 人中有 3 人觉得有帮助